博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU Hat's Fibonacci
阅读量:6438 次
发布时间:2019-06-23

本文共 1446 字,大约阅读时间需要 4 分钟。

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 268 Accepted Submission(s): 112
Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 
Input
Each line will contain an integers. Process to end of file.
 
Output
For each case, output the result in a line.
 
Sample Input
100
 
Sample Output
4203968145672990846840663646Note:No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 
用二维数组模拟大数加法,每一行表述一个数,每一行的一个元素可以代表n位数,这个可以根据自己的需要自己定义。
其他的就和正常的加法一样了,注意进位处理。
 
#include <iostream>
#include <stdio.h>
using namespace
 std;
int
 s[7500][670];
void
 solve(){
    s[1][1] = 1;s[2][1] = 1;
    s[3][1] = 1;s[4][1] = 1;
    int
 i,j,k=0;
    for
(i = 5;i<7500;i++)
    for
( j = 1;j<=670 ;j++)
    {
        k += s[i-1][j]+s[i-2][j]+s[i-3][j]+s[i-4][j];
        s[i][j] = k%10000;
        k = k/10000;
    }
    while
(k)
    {
        s[i][j++] = k%10000;
        k = k/10000;
    }
}
int
 main()
{
    int
 n,i,j;
    solve();
    while
(cin>>n)
    {
        for
(i = 670; i>=1;i--)
        if
(s[n][i]!=0)break;
        printf("%d",s[n][i]);
        for
(j = i-1;j>=1;j--)
        printf("%04d",s[n][j]);
        printf("\n");
    }
}
本文转自NewPanderKing51CTO博客,原文链接:
http://www.cnblogs.com/newpanderking/archive/2011/07/31/2122528.html
 ,如需转载请自行联系原作者
你可能感兴趣的文章
《数字短片创作(修订版)》——第一部分 剧本创作 第1章 数字短片创意技法 剧本创作的构思...
查看>>
MIT 学生挑战新泽西索取挖矿程序源代码的要求
查看>>
实践 | 不同行业WMS选型策略及需要注意的一些问题
查看>>
MaxCompute与OSS非结构化数据读写互通(及图像处理实例)
查看>>
【F3简介】一张图看懂FPGA-F3实例
查看>>
bash环境(变量与bash配置文件)
查看>>
Server Hard drive mode
查看>>
smb服务器配置过程遇到错误及解决
查看>>
java杂乱
查看>>
在Linux上安装Python3.6.1
查看>>
[基础]iOS 可视化编程(全系列)
查看>>
我的友情链接
查看>>
LVS之NAT模型配置实验
查看>>
nginx 报错 99: Cannot assign requested address
查看>>
几种流行的AJAX框架:jQuery,Mootools,Dojo,Ext JS的对比
查看>>
Socket-Client通信
查看>>
Maven搭建简单的SS项目
查看>>
#我要上首页# 新版博客首页来了,做明星博主还会远吗?
查看>>
PHP缓存技术
查看>>
关于SOCKET资源堆栈
查看>>